वर्डप्रेस 2.1.1 “खतरनाक” है

यह समाचार उन लोगों के लिए है जो वर्डप्रेस को अपने सर्वर पर प्रयोग कर रहे हैं। वर्डप्रेस के द्वारा जारी नई खबर के अनुसार वर्डप्रेस का अब तक का नवीनतम संस्करण 2.1.1 असुरक्षित ही नहीं “खतरनाक” है। यदि आप ने वर्डप्रेस 2.1.1 को पिछले तीन चार दिन में डाउनलड कर इन्सटाल किया है, तो फटाफट 2.1.2 डाउनलोड कर के उसे ओवर-राइट करें।

वर्डप्रेस वाले बताते हैं कि किसी अनधिकृत व्यक्ति ने वर्डप्रेस के सर्वर में सेन्ध लगा कर डाउनलोड फाइल को ही बदल डाला, और उस में दो फाइलों को इस तरह बदला कि आप के सर्वर पर PHP फाइलों को बाहर से चलाया जा सकता है। पूरी सूचना आप वर्डप्रेस की साइट पर पढ़ सकते हैं

कल ही श्रीश ने वर्डप्रेस के विषय में एक जानकारीपूर्ण लेख लिखा था, और उस में बताया था

सॉफ्टवेयर का नया संस्करण आने पर आपको सॉफ्टवेयर को स्वयं अपग्रेड करना होगा।

यही नहीं, आप को इस तरह की चीज़ों का ध्यान रखना होगा, यह ध्यान रखना होगा कि नया संस्करण कब आ रहा है, और इस तरह की कोई सुरक्षा संबन्धी समस्या तो नहीं है। जैसा कि अमित ने बताया कि

जो सेवाएँ एक क्लिक इंस्टॉल वाली सुविधा देती हैं वे एक क्लिक पर अपग्रेड की सुविधा भी देती हैं।

उम्मीद है कि ऐसी सेवाएँ एकदम नया संस्करण उपलब्ध कराएँगी। मेरा पहले का अनुभव यह रहा है, कि फैंटास्टिको जैसी सेवाएँ अक्सर नवीनतम संस्करण उपलब्ध नहीं करातीं। शायद उस में अब कुछ सुधार आ गया हो।

Join the Conversation

3 Comments

  1. यह तो वाकई चिंता की बात है हमारे कई साथी संस्करण २.१.१ का प्रयोग कर रहे हैं। वो तो शुक्र है कि हिन्दी जगत में अभी अपराधी किस्म के लोग नहीं हैं।

  2. उम्मीद है कि ऐसी सेवाएँ एकदम नया संस्करण उपलब्ध कराएँगी। मेरा पहले का अनुभव यह रहा है, कि फैंटास्टिको जैसी सेवाएँ अक्सर नवीनतम संस्करण उपलब्ध नहीं करातीं। शायद उस में अब कुछ सुधार आ गया हो।

    मेरा इशारा फैन्टॉस्टिको की ओर ही था, सबसे अधिक प्रचलित one click install वाला जुगाड़ वही है, वैसे कुछ वेबहोस्ट अपने खुद के जुगाड़ भी प्रदान करते हैं। जितना मैंने अनुभव किया है, फैन्टॉस्टिको वाले एकदम से नया संस्करण नहीं उपलब्ध करवाते। बल्कि जब कोई संस्करण थोड़ा स्टेबल हो जाता है तभी उपलब्ध करवाते हैं। अब यह कुछ मामलों में सही है और कुछ में नहीं भी।

    वो तो शुक्र है कि हिन्दी जगत में अभी अपराधी किस्म के लोग नहीं हैं।

    भाया, यह कोई आवश्यक है कि किसी हिन्दी के वर्डप्रैस ब्लॉग पर हमला करने के लिए हिन्दी ब्लॉगजगत से ही होना पड़ेगा!! 😉

Leave a comment

Your email address will not be published. Required fields are marked *